Microsoft "Fix it" doesn't!

Discussion in 'Bloody Computers' started by MG Maniac, Nov 27, 2013.

Welcome to the Navy Net aka Rum Ration

The UK's largest and busiest UNofficial RN website.

The heart of the site is the forum area, including:

  1. Damn Pute is causing me some severe grief at present! Bought a new camera a couple of weeks ago and when trying to down load the pics the pute wouldn't recognise the camera ... said it was attached but wouldn't play! Not to be outsmarted by a chunk on plastic I got my trusty SD card reader out but nada ... wouldn't play with it either .. knew it worked as took it to work and downloaded all from there no problem! Its not the USB port either as put in a card I had used on the pute for ages and it worked in straight away. So problem seems to be any new USB devices.

    Got onto the XP site and downloaded Microsoft's "Fit It" programme which I ran but still no joy! The blurb on Microsoft site says its a corruption in the registry but nothing I could see as how to fix it manually or what I was supposed to be looking at.

    Anyone else suffered anythig similar and what did they do to get it working again???
  2. Remove all the data you want to keep to a external hard drive or memory stick, roll the PC in breadcrumbs, deep fat fry it then ditch it and buy a new one, is that of any help?
    Last edited: Nov 27, 2013
  3. I had the same problem with an old video camera and a PC using Windows 7. Nothing would work so I got the old one out of the loft (running XP) and had to do it that way.
  4. In a word ... no!
  5. Had the same with a Fuji camera. I was using the cable for my other gear then read about subtle differences in cables so I took the cable from my external HDD and tried that. It worked!! So I thought I'd again try the original cable and no go.. If not that then it's possible you haven't the correct driver which you should be able to get from the makers website. :)
  6. Yep, bizarrely agree with that! Cables that look identical will work happily with one thing, but not another.
  7. Quite agree ... but when you have a brand new flash drive so no cables and it still doesn't work ... its so 'kin frustrating! ... and before you say anything Monty ... I don't want a Mac Book! ... other than I cant afford one!
  8. At least your Fix It didn't hang up because of an out of date version of Netframework somethingorother; to be then invited to use "Fix It" to solve it. Good old MS, I thought. Bollox! it took me to a page that thanked me for taking part in the Fix It trial and that it was nolonger available.

    When you download your pictures, be sure to view them at full screen before deleting them from the camera. I've had occasions where it has transferred to the computer, showing the all OK "thumbnail" and a file size looking about right, to then have odd coloured lines or blank lines when viewed full size.
  9. Yes. So I replaced all my PCs with macs. No problems since.
  10. Obviously paying AC's pop star wages now? :)

    Posted from the Navy Net mobile app (Android / iOS)
  11. We're the rock stars of the FAA baby.
    • Like Like x 2
  12. sgtpepperband

    sgtpepperband War Hero Moderator Book Reviewer

    What, you're into kids..? :shock: :twisted:
    • Like Like x 1
  13. MG, before you plug it in, go to device manager and look at USB controllers, then plug in the camera and see if it displays as a device, then check properties (right click on the device that looks to be the camera) to see if windows thinks its working properly. If not, you can install/uninstall driver, some support troubleshooting and have a button for it, success is mixed dependant on the nature of the fault (bad driver, cable etc)

    This is what it looks like in Win7, XP is similar.

    Are you running XP or 7? If you're running XP, it has problems addressing SDHC cards (SD and SD high capacity are different), since they are over 4Gb in memory, most newer digital cams likely have 16Gb cards or better. Theres a hotfix for XP Hotfix for Windows XP that adds support for SDHC cards that have a capacity of more than 4 GB
    If that doesnt work, post your camera make and model and Computer make/model/OS (you can find make/model/OS details by right clicking my computer>properties e.g. Win XP 32 bit service pack 3 Dell 610 startyoubastard with intel oomebollocks processor)
    Last edited: Nov 28, 2013
    • Like Like x 1
  14. Agree with Ships Cat, High Capacity memory cards do cause problems in XP and I have seen 7 have problems but that was the card reader as it wasn't capable of using HC cards.
    Go to your local PC shop with card, tell them what system you run and get a suitable reader. Some software supplied with cameras actually makes the camera behave as a card reader but appears as a camera.
    alternatively, go to a big boots or camera shop and transfer them directly onto CD
  15. Ahh! Now that could be the issue as card is a 16Gb. Stupid thing is I have a 16Gb flash drive that I used with the system with no problems but it might just be the 16Gb SDHC card thats the issue! Thanks for the link ... will try that! Cheers guys!
  16. Don't know if it makes any difference what format the cards are currently in (FAT32/NTFS?). Having only elderly pc's and Laptops in my posession - it's all got to be FAT32 or else things get a tad stressful. Probably wrong because I know nothing.

    Please ignore this if it does not help.
  17. 32 bit 64 bit FAT ... its all gobbledegook to me too! I can put the things together ... they are just a big airfix kit and I've built every pute I've ever had from scratch ... but when it comes to what makes 'em work thats a whole new ball game which I leave to them that know!
  18. Agree with ships cat and drewfester above. The card will say SDHC on it if it is an HC - highly likey - and this means that a reader not designed for an HC card wont work. I am surprised that plugging the camera in doesn't though as normally it will translate as a 'normal' mass storage device (like your 16GB flash drive).

    SC's advice about the device manager is good. Control Panel - System - Device Manager. When the camera is plugged in look for any yellow warning triangles and then do the right click update driver stuff described above.

    Clearly this is easy to type if you know what it means, but perhaps less easy to explain well.
  19. Put more succinctly by wiki>

    Host devices that accept SDHC cards are required to accept SDSC (standard capacity) cards.[SUP][1][/SUP] However, host devices designed for SDSC do not recognize SDHC or SDXC memory cards, although some devices can do so through a firmware upgrade.[SUP][8][/SUP] Older operating systems require patches to support SDHC. For instance, Microsoft Windows XP before SP3 requires a patch to support access to SDHC cards.[SUP][9][/SUP] Windows Vista also requires service pack 2.[SUP][10][/SUP][SUP][11]
    • Like Like x 1
  20. Yeup ... did that! however a) pute can't find the appropriate driver and b) the camera should be in the "scanners & camera" slot on device manager however pute put it in "Other devices" ... Nikon blurb say that if that happens then delete it as it won't work from there however I can't "drag and drop" it in device manager and turning the camera off and on doesn't sort the issue.

    I agree ... Windows should have recognised it as a mass storage device however have downloaded the "hotfix" and when I get chance to play will see what happens then.

    Cheers for the help and suggestions guys

Share This Page