BT internet email problems

#1
Today I've been unable to log in to either of my BT email addresses (*********@btinternet.com).
(Laptop with Win 10, both Browsers Edge & IE11 seem OK)

At the log in page [https://signin1.bt.com/login/emailloginform] my email address and PW are entered per usual.

Next, on ticking the blue 'Sign in Box' that blue coloured box changes to grey but thereafter the whole page stays the same and nothing else happens.

Are there any other btinternet.com email users having a similar problem or is it just at my end?

Any advice welcomed, please.
 
#5
^^^Thanks for confirming it's OK elsewhere, folks.

|I finally managed to log in but by only by downloading another browser (Chrome) and oddly enough the same Log In page there works OK (but that page on either of the other two, IE & Edge are still not working - Electronic equivalent of pull through with a Christmas tree needed, Grrrr!)
 
#6
I abandoned IE and Edge 12 months ago as it allowed some Ransom Ware to get on my pooter despite taking all the necessary steps to avoid it. I switched to Chrome and have been trouble free since.
 

janner

MIA
Book Reviewer
#7
I had all sorts of things creeping in to my pooter when I used edge, briefly, spoke to a man in Mumbai about the problems and was advised to ditch edge and use chrome, did so and things have been better since.
 
#8
Thing is with Chrome they leave you alone , I have had about 6 messages in the same number of years asking me to click an update , MS on the other hand are always suggesting things you do not need , and it used to crash quite a bit.
 
G

guestm

Guest
#9
Today I've been unable to log in to either of my BT email addresses (*********@btinternet.com).
(Laptop with Win 10, both Browsers Edge & IE11 seem OK)

At the log in page [https://signin1.bt.com/login/emailloginform] my email address and PW are entered per usual.

Next, on ticking the blue 'Sign in Box' that blue coloured box changes to grey but thereafter the whole page stays the same and nothing else happens.

Are there any other btinternet.com email users having a similar problem or is it just at my end?

Any advice welcomed, please.
BOB, I had this problem. If you clear your cache, it goes away. I ended up ditching my btinternet account anyway, problems like that AND terrible security.
 
#12
Have a real good look through the customise page Bob , a series of 3 small dots in the very top right hand corner below X , Settings , blocking stuff you do not want . BTW I sent a PM last week under Stirlin log in , you may have missed it.
Sigh - Another learning curve, bit diffs with some of the 'Two-Stick Groundhog Days' I'm into just now (Cue Violins...) but nonetheless ta muchly.

Re: PMs - Spotted, Replied & Invited.
 
#13
My mum is always having snags with her BT Internet email, she uses an Ipad and cant get it to work with the email app. She has to go into the BT Internet website, click on the mail icon and log in every time.
 

Similar threads

Latest Threads

Top